Debian Security Advisory

DSA-3005-1 gpgme1.0 -- security update

Date Reported:
14 Aug 2014
Affected Packages:
gpgme1.0
Vulnerable:
Yes
Security database references:
In the Debian bugtracking system: Bug 756651.
In Mitre's CVE dictionary: CVE-2014-3564.
More information:

Tomรกลก Trnka discovered a heap-based buffer overflow within the gpgsm status handler of GPGME, a library designed to make access to GnuPG easier for applications. An attacker could use this issue to cause an application using GPGME to crash (denial of service) or possibly to execute arbitrary code.

For the stable distribution (wheezy), this problem has been fixed in version 1.2.0-1.4+deb7u1.

For the testing distribution (jessie), this problem has been fixed in version 1.5.1-1.

For the unstable distribution (sid), this problem has been fixed in version 1.5.1-1.

We recommend that you upgrade your gpgme1.0 packages.