Bulletin d'alerte Debian

DSA-3012-1 eglibc -- Mise à jour de sécurité

Date du rapport :
27 août 2014
Paquets concernés :
eglibc
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le dictionnaire CVE du Mitre : CVE-2014-5119.
Plus de précisions :

Tavis Ormandy a découvert un dépassement de tas dans le code de chargement du module de transcription d'eglibc, la version de Debian de la bibliothèque GNU C. En conséquence, un attaquant qui peut fournir un jeu de caractères contrefait, en argument aux fonctions de conversion de caractères liées à iconv pourrait exécuter du code arbitraire.

Cette mise à jour supprime la prise en charge des modules chargeables de transcription de gconv. En plus de la vulnérabilité de sécurité, le code de chargement du module présente des défauts de fonctionnalité qui l'empêchent de fonctionner comme prévu.

Pour la distribution stable (Wheezy), ce problème a été corrigé dans la version 2.13-38+deb7u4.

Nous vous recommandons de mettre à jour vos paquets eglibc.