Bulletin d'alerte Debian

DSA-3016-1 lua5.2 -- Mise à jour de sécurité

Date du rapport :
1er septembre 2014
Paquets concernés :
lua5.2
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le dictionnaire CVE du Mitre : CVE-2014-5461.
Plus de précisions :

Une vulnérabilité de dépassement de tas a été découverte dans la façon dont Lua, un langage de programmation simple, extensible et embarquable, gère les fonctions varargs ayant beaucoup de paramètres fixes et appelées avec peu d'arguments. Cela peut mener au plantage d'applications ou, éventuellement, à l'exécution de code arbitraire.

Pour la distribution stable (Wheezy), ce problème a été corrigé dans la version 5.2.1-3+deb7u1.

Pour la distribution testing (Jessie), ce problème a été corrigé dans la version 5.2.3-1.

Pour la distribution unstable (Sid), ce problème a été corrigé dans la version 5.2.3-1.

Nous vous recommandons de mettre à jour vos paquets lua5.2.