Debians sikkerhedsbulletin

DSA-3017-1 php-cas -- sikkerhedsopdatering

Rapporteret den:
2. sep 2014
Berørte pakker:
php-cas
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Debians fejlsporingssystem: Fejl 759718.
I Mitres CVE-ordbog: CVE-2014-4172.
Yderligere oplysninger:

Marvin S. Addison opdagede at Jasig phpCAS, et PHP-bibliotek til autentifikationsprotokollen CAS, ikke encodede tickets før de blev føjet til en URL, hvilket gjorde det muligt at udføre skripter på tværs af servere.

I den stabile distribution (wheezy), er dette problem rettet i version 1.3.1-4+deb7u1.

Den ustabile distribution (sid) vil snart blive rettet.

Vi anbefaler at du opgraderer dine php-cas-pakker.