Debian セキュリティ勧告

DSA-3017-1 php-cas -- セキュリティ更新

報告日時:
2014-09-02
影響を受けるパッケージ:
php-cas
危険性:
あり
参考セキュリティデータベース:
Debian バグ追跡システム: バグ 759718.
Mitre の CVE 辞書: CVE-2014-4172.
詳細:

Marvin S. Addison さんが、CAS認証プロトコルを扱うPHPライブラリ Jasig phpCAS がチケットをURLに追加する前にURLエンコードしていないことを発見しました。 クロスサイトスクリプティングの余地を与えます。

安定版 (stable) ディストリビューション (wheezy) では、この問題はバージョン 1.3.1-4+deb7u1 で修正されています。

不安定版 (unstable) ディストリビューション (sid) では近く修正予定です。

直ちに php-cas パッケージをアップグレードすることを勧めます。