Debians sikkerhedsbulletin

DSA-3035-1 bash -- sikkerhedsopdatering

Rapporteret den:
25. sep 2014
Berørte pakker:
bash
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Debians fejlsporingssystem: Fejl 762760, Fejl 762761.
I Mitres CVE-ordbog: CVE-2014-7169.
Yderligere oplysninger:

Tavis Ormandy opdagede at rettelsen af CVE-2014-6271 udgivet i DSA-3032-1 vedrørende bash, GNU Bourne-Again Shell, var ufuldstændig og stadig kunne gøre det muligt at indsprøjte nogle tegn i et andet miljø (CVE-2014-7169). Denne opdatering tilføjes præfiks og suffiks til miljøvariabelnavne indeholdede shellfunktioner, som en hærdende foranstaltning.

Desuden rettes to arraytilgange uden for grænserne i bash-fortolkeren, som blev afsløret under Red Hats interne analyse af problemerne, samt uafhængigt rapporteret af Todd Sabin.

I den stabile distribution (wheezy), er disse problemer rettet i version 4.2+dfsg-0.1+deb7u3.

Vi anbefaler at du opgraderer dine bash-pakker.