Bulletin d'alerte Debian

DSA-3035-1 bash -- Mise à jour de sécurité

Date du rapport :
25 septembre 2014
Paquets concernés :
bash
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le système de suivi des bogues Debian : Bogue 762760, Bogue 762761.
Dans le dictionnaire CVE du Mitre : CVE-2014-7169.
Plus de précisions :

Tavis Ormandy a découvert que le correctif appliqué pour régler le problème CVE-2014-6271 publié dans DSA-3032-1 pour bash, le GNU Bourne-Again Shell, était incomplet et pourrait toujours permettre à quelques caractères d'être injectés dans un autre environnement (CVE-2014-7169). Avec cette mise à jour, un préfixe et un suffixe sont ajoutés aux noms des variables d'environnement contenant des fonctions shell en guise de mesure de renforcement.

De plus, deux accès hors limites de tableaux dans l'analyseur bash sont corrigés. Ceux-ci ont été révélés par l'analyse interne de Red Hat pour ces problèmes et signalés indépendamment par Todd Sabin.

Pour la distribution stable (Wheezy), ces problèmes ont été corrigés dans la version 4.2+dfsg-0.1+deb7u3.

Nous vous recommandons de mettre à jour vos paquets bash.