Bulletin d'alerte Debian

DSA-3062-1 wget -- Mise à jour de sécurité

Date du rapport :
1er novembre 2014
Paquets concernés :
wget
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le système de suivi des bogues Debian : Bogue 766981.
Dans le dictionnaire CVE du Mitre : CVE-2014-4877.
Plus de précisions :

HD Moore de Rapid7 a découvert une attaque par lien symbolique dans Wget, un outil en ligne de commande pour récupérer des fichiers par HTTP, HTTPS et FTP. La vulnérabilité permet la création de fichiers arbitraires dans le système de l'utilisateur quand Wget est exécuté en mode récursif auprès d'un serveur FTP malveillant. La création de fichiers arbitraires peut écraser le contenu de fichiers de l'utilisateur ou permettre l'exécution de code distant avec les droits de l'utilisateur.

Cette mise à jour change la configuration par défaut de Wget de manière à ce qu'il ne crée plus de liens symboliques locaux, mais les traverse plutôt et récupère les fichiers pointés dans ce type de récupération.

Pour la distribution stable (Wheezy), ce problème a été corrigé dans la version 1.13.4-3+deb7u2.

Pour la distribution unstable (Sid), ce problème a été corrigé dans la version 1.16-1.

Nous vous recommandons de mettre à jour vos paquets wget.