Debians sikkerhedsbulletin

DSA-3065-1 libxml-security-java -- sikkerhedsopdatering

Rapporteret den:
6. nov 2014
Berørte pakker:
libxml-security-java
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Debians fejlsporingssystem: Fejl 720375.
I Mitres CVE-ordbog: CVE-2013-2172.
Yderligere oplysninger:

James Forshaw opdagede at i Apache Santuario XML Security for Java, blev CanonicalizationMethod-parametre valideret på forkert vis; ved at angive en vilkårlig svag kanonikaliseringsalgoritme, kunne en angriber forfalske XML-signaturer.

I den stabile distribution (wheezy), er dette problem rettet i version 1.4.5-1+deb7u1.

I distributionen testing (jessie), er dette problem rettet i version 1.5.5-2.

I den ustabile distribution (sid), er dette problem rettet i version 1.5.5-2.

Vi anbefaler at du opgraderer dine libxml-security-java-pakker.