Säkerhetsbulletin från Debian

DSA-3067-1 qemu-kvm -- säkerhetsuppdatering

Rapporterat den:
2014-11-06
Berörda paket:
qemu-kvm
Sårbara:
Ja
Referenser i säkerhetsdatabaser:
I Mitres CVE-förteckning: CVE-2014-3689, CVE-2014-7815.
Ytterligare information:

Flera sårbarheter har upptäckts i qemu-kvm, en komplett virtualiseringslösning på x86-hårdvara.

  • CVE-2014-3689

    Advanced Threat Research-gruppen på Intel Security rapporterade att parametrar som tillhandahålls av gäster valideras otillräckligt i rektangelfunktioner i drivrutinen vmware-vga. En priviligierad gästanvändare kunde använda denna brist för att skriva i qemu's addressrymd på värden, och därmed potentiellt öka sina rättigheter till de av qemu-värdens rättigheter.

  • CVE-2014-7815

    James Spadaro på Cisco rapporterade otillräckligt rengjorda bits_per_pixel från klienten i QEMU VNC-displaydrivrutinerna. En angripare med åtkomst till gästens VNC-konsoll kunde använda denna brist för att krascha gästen.

För den stabila utgåvan (Wheezy) har dessa problem rättats i version 1.1.2+dfsg-6+deb7u5.

Vi rekommenderar att ni uppgraderar era qemu-kvm-paket.