Debian セキュリティ勧告

DSA-3102-1 libyaml -- セキュリティ更新

報告日時:
2014-12-13
影響を受けるパッケージ:
libyaml
危険性:
あり
参考セキュリティデータベース:
Debian バグ追跡システム: バグ 771366.
Mitre の CVE 辞書: CVE-2014-9130.
詳細:

Jonathan Gray さんと Stanislaw Pitucha さんが、高速な YAML 1.1 パーサ及び生成ライブラリ LibYAML が折り返された文字列を解析する方法にアサート失敗を発見しました。libyaml を利用しているアプリケーションで、特別に細工した YAML 入力をロードさせることのできる攻撃者が、 アプリケーションをクラッシュさせることが可能です。

安定版 (stable) ディストリビューション (wheezy) では、この問題はバージョン 0.1.4-2+deb7u5 で修正されています。

次期安定版 (stable) ディストリビューション (jessie) では、この問題はバージョン 0.1.6-3 で修正されています。

不安定版 (unstable) ディストリビューション (sid) では、この問題はバージョン 0.1.6-3 で修正されています。

直ちに libyaml パッケージをアップグレードすることを勧めます。