Bulletin d'alerte Debian

DSA-3111-1 cpio -- Mise à jour de sécurité

Date du rapport :
22 décembre 2014
Paquets concernés :
cpio
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le système de suivi des bogues Debian : Bogue 772793.
Dans le dictionnaire CVE du Mitre : CVE-2014-9112.
Plus de précisions :

Michal Zalewski a découvert un problème d'écriture hors limites dans cpio, un utilitaire pour créer et extraire des fichiers d'archive au format cpio. Lors de la correction de ce problème, les développeurs de cpio ont découvert et corrigé des problèmes supplémentaires de vérification d'intervalle et de déréférencement de pointeur NULL.

Pour la distribution stable (Wheezy), ce problème a été corrigé dans la version 2.11+dfsg-0.1+deb7u1.

Pour la prochaine distribution stable (Jessie), ce problème sera corrigé prochainement.

Pour la distribution unstable (Sid), ce problème a été corrigé dans la version 2.11+dfsg-4.

Nous vous recommandons de mettre à jour vos paquets cpio.