Debian セキュリティ勧告

DSA-3111-1 cpio -- セキュリティ更新

報告日時:
2014-12-22
影響を受けるパッケージ:
cpio
危険性:
あり
参考セキュリティデータベース:
Debian バグ追跡システム: バグ 772793.
Mitre の CVE 辞書: CVE-2014-9112.
詳細:

Michal Zalewski さんが、cpio アーカイブファイルを作成、抽出するツール cpio に範囲外書き込みの問題を発見しています。この問題を修正する過程で cpio 開発者が範囲確認と NULL ポインタ参照の問題を追加で発見、修正しています。

安定版 (stable) ディストリビューション (wheezy) では、この問題はバージョン 2.11+dfsg-0.1+deb7u1 で修正されています。

次期安定版 (stable) ディストリビューション (jessie) ではこの問題は近く修正予定です。

不安定版 (unstable) ディストリビューション (sid) では、この問題はバージョン 2.11+dfsg-4 で修正されています。

直ちに cpio パッケージをアップグレードすることを勧めます。