Рекомендация Debian по безопасности

DSA-3111-1 cpio -- обновление безопасности

Дата сообщения:
22.12.2014
Затронутые пакеты:
cpio
Уязвим:
Да
Ссылки на базы данных по безопасности:
В системе отслеживания ошибок Debian: Ошибка 772793.
В каталоге Mitre CVE: CVE-2014-9112.
Более подробная информация:

Михал Залевский обнаружил чтение за пределами массива в cpio, инструменте для создания и распаковки архивов cpio. В процессе исправления данной проблемы разработчики cpio обнаружили и исправили проверку диапазонов и разыменование null-указателя.

В стабильном выпуске (wheezy) эта проблема была исправлена в версии 2.11+dfsg-0.1+deb7u1.

В готовящемся стабильном выпуске (jessie) эта проблема будет исправлена позже.

В нестабильном выпуске (sid) эта проблема была исправлена в версии 2.11+dfsg-4.

Рекомендуется обновить пакеты cpio.