Debian セキュリティ勧告

DSA-3112-1 sox -- セキュリティ更新

報告日時:
2014-12-23
影響を受けるパッケージ:
sox
危険性:
あり
参考セキュリティデータベース:
Debian バグ追跡システム: バグ 773720.
Mitre の CVE 辞書: CVE-2014-8145.
詳細:

Google セキュリティチームの Michele Spagnuolo さんが万能音声処理プログラム SoX にヒープベースのバッファオーバーフローを2件発見しています。特別に細工した wav ファイルにより SoX を利用しているアプリケーションのクラッシュや、 潜在的には任意のコードの実行を引き起こすことが可能です。

安定版 (stable) ディストリビューション (wheezy) では、この問題はバージョン 14.4.0-3+deb7u1 で修正されています。

次期安定版 (stable) ディストリビューション (jessie) 及び不安定版 (unstable) ディストリビューション (sid) では、この問題は近く修正予定です。

直ちに sox パッケージをアップグレードすることを勧めます。