Рекомендация Debian по безопасности

DSA-3112-1 sox -- обновление безопасности

Дата сообщения:
23.12.2014
Затронутые пакеты:
sox
Уязвим:
Да
Ссылки на базы данных по безопасности:
В системе отслеживания ошибок Debian: Ошибка 773720.
В каталоге Mitre CVE: CVE-2014-8145.
Более подробная информация:

Мишель Спагнуоло из Google Security Team обнарули два переполнения динамической памяти в SoX, наборе инструментов для обрабатывающих звук программ. Специально сформированный файл в формате wav может привести к аварийному завершению работы приложения, использующего SoX, либо к выполнению произвольного кода.

В стабильном выпуске (wheezy) эти проблемы были исправлены в версии 14.4.0-3+deb7u1.

В готовящемся стабильном (jessie) и нестабильном (sid) выпусках эти проблемы будут исправлены позже.

Рекомендуется обновить пакеты sox.