Debians sikkerhedsbulletin

DSA-3113-1 unzip -- sikkerhedsopdatering

Rapporteret den:
28. dec 2014
Berørte pakker:
unzip
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Debians fejlsporingssystem: Fejl 773722.
I Mitres CVE-ordbog: CVE-2014-8139, CVE-2014-8140, CVE-2014-8141.
Yderligere oplysninger:

Michele Spagnuolo fra Google Security Team opdagede at unzip, et udpakningsværktøj til arkiver komprimeret i .zip-formatet, var påvirket af et heapbaseret bufferoverløb i funktionen til CRC32-verifikation (CVE-2014-8139), i funktionen test_compr_eb() (CVE-2014-8140) og i funktionen getZip64Data() (CVE-2014-8141), hvilke kunne føre til udførelse af vilkårlig kode.

I den stabile distribution (wheezy), er disse problemer rettet i version 6.0-8+deb7u1.

I den kommende stabile distribution (jessie), vil disse problemer snart blive rettet.

I den ustabile distribution (sid), er disse problemer rettet i version 6.0-13.

Vi anbefaler at du opgraderer dine unzip-pakker.