Рекомендация Debian по безопасности

DSA-3117-1 php5 -- обновление безопасности

Дата сообщения:
31.12.2014
Затронутые пакеты:
php5
Уязвим:
Да
Ссылки на базы данных по безопасности:
В каталоге Mitre CVE: CVE-2014-8142.
Более подробная информация:

В PHP, языке сценариев общего назначения, часто используемом для разработки веб-приложений, были обнаружены несколько уязвимостей.

Как было сообщено в DSA 3064-1, команда безопасности решила следовать стабильным выпускам версии 5.4.x для пакетов php5 в Wheezy. Следовательно, уязвимости решаются путём обновления PHP до новой версии основной ветки разработки, в данном случае версии 5.4.36, которая включает в себя дополнительные исправления ошибок, новые возможности и может включать несовместимые изменения. Дополнительную информацию см. в журнале изменений основной ветки разработки:

http://php.net/ChangeLog-5.php#5.4.36

Две дополнительных заплаты были применены к новой версии из основной ветки разработки. Было исправлено чтение за пределами массива, которое могло приводить к аварийному завершению работы php5-cgi. Более того, была исправлена ошибка, возникающая при совместной работе php5-pgsql и PostgreSQL 9.1 (ошибка Debian #773182).

В стабильном выпуске (wheezy) эти проблемы были исправлены в версии 5.4.36-0+deb7u1.

Рекомендуется обновить пакеты php5.