Bulletin d'alerte Debian

DLA-181-1 xerces-c -- Mise à jour de sécurité pour LTS

Date du rapport :
27 mars 2015
Paquets concernés :
xerces-c
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le système de suivi des bogues Debian : Bogue 780827.
Dans le dictionnaire CVE du Mitre : CVE-2015-0252.
Plus de précisions :

Anton Rager et Jonathan Brossard de l'équipe de sécurité des produits de Salesforce.com et Ben Laurie de Google ont découvert une vulnérabilité de déni de service dans xerces-c, une bibliothèque d'analyse de validation de XML pour C++. L'analyseur ne gère pas correctement certains types de documents malformés en entrée, résultant en une erreur de segmentation lors de l'opération d'analyse. Un attaquant non authentifié pourrait utiliser ce défaut pour provoquer le plantage d'une application utilisant la bibliothèque xerces-c.

Pour Debian 6 Squeeze, ces problèmes ont été corrigé dans xerces-c version 3.1.1-1+deb6u1