Debian Security Advisory

DLA-272-1 python-django -- LTS security update

Date Reported:
16 Jul 2015
Affected Packages:
python-django
Vulnerable:
Yes
Security database references:
In Mitre's CVE dictionary: CVE-2015-2317, CVE-2015-5143, CVE-2015-5144.
More information:

Several vulnerabilities were discovered in Django, a high-level Python web development framework:

  • CVE-2015-2317

    Daniel Chatfield discovered that python-django, a high-level Python web development framework, incorrectly handled user-supplied redirect URLs. A remote attacker could use this flaw to perform a cross-site scripting attack.

  • CVE-2015-5143

    Eric Peterson and Lin Hua Cheng discovered that a new empty record used to be created in the session storage every time a session was accessed and an unknown session key was provided in the request cookie. This could allow remote attackers to saturate the session store or cause other users' session records to be evicted.

  • CVE-2015-5144

    Sjoerd Job Postmus discovered that some built-in validators did not properly reject newlines in input values. This could allow remote attackers to inject headers in emails and HTTP responses.

For the oldoldstable distribution (squeeze), these problems have been fixed in version 1.2.3-3+squeeze13.