Debian Security Advisory

DSA-3181-1 xen -- security update

Date Reported:
10 Mar 2015
Affected Packages:
xen
Vulnerable:
Yes
Security database references:
In Mitre's CVE dictionary: CVE-2015-2044, CVE-2015-2045, CVE-2015-2151.
More information:

Multiple security issues have been found in the Xen virtualisation solution:

  • CVE-2015-2044

    Information leak via x86 system device emulation.

  • CVE-2015-2045

    Information leak in the HYPERVISOR_xen_version() hypercall.

  • CVE-2015-2151

    Missing input sanitising in the x86 emulator could result in information disclosure, denial of service or potentially privilege escalation.

In addition the Xen developers reported an unfixable limitation in the handling of non-standard PCI devices. Please refer to http://xenbits.xen.org/xsa/advisory-124.html for further information.

For the stable distribution (wheezy), these problems have been fixed in version 4.1.4-3+deb7u5.

For the unstable distribution (sid), these problems will be fixed soon.

We recommend that you upgrade your xen packages.