Bulletin d'alerte Debian

DSA-3198-1 php5 -- Mise à jour de sécurité

Date du rapport :
20 mars 2015
Paquets concernés :
php5
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le dictionnaire CVE du Mitre : CVE-2015-2301, CVE-2015-2331, CVE-2015-2348, CVE-2015-2787.
Plus de précisions :

Plusieurs vulnérabilités ont été découvertes dans le langage PHP :

  • CVE-2015-2301

    Utilisation de mémoire après libération dans l'extension phar.

  • CVE-2015-2331

    Emmanuel Law a découvert un dépassement d'entier dans le traitement des archives ZIP, résultant en un déni de service ou éventuellement l'exécution de code arbitraire.

Pour la distribution stable (Wheezy), ces problèmes ont été corrigés dans la version 5.4.39-0+deb7u1. Cette mise à jour corrige également une régression dans la prise en charge de curl introduite dans DSA 3195.

Pour la distribution unstable (Sid), ces problèmes seront corrigés prochainement.

Nous vous recommandons de mettre à jour vos paquets php5.