Рекомендация Debian по безопасности

DSA-3198-1 php5 -- обновление безопасности

Дата сообщения:
20.03.2015
Затронутые пакеты:
php5
Уязвим:
Да
Ссылки на базы данных по безопасности:
В каталоге Mitre CVE: CVE-2015-2301, CVE-2015-2331, CVE-2015-2348, CVE-2015-2787.
Более подробная информация:

В языке PHP были обнаружены многочисленные уязвимости:

  • CVE-2015-2301

    Использование указателей после освобождения памяти в расширении phar.

  • CVE-2015-2331

    Эммануэль Лоу обнаружил переполнение целых чисел в коде обработки архивов ZIP, приводящее к отказу в обслуживании или потенциальному выполнению произвольного кода.

В стабильном выпуске (wheezy) эти проблемы были исправлены в версии 5.4.39-0+deb7u1. Кроме того, данное обновление содержит исправление регресса в поддержке curl, возникшей в DSA 3195.

В нестабильном выпуске (sid) эти проблемы будут исправлены позже.

Рекомендуется обновить пакеты php5.