Bulletin d'alerte Debian

DSA-3247-1 ruby2.1 -- Mise à jour de sécurité

Date du rapport :
2 mai 2015
Paquets concernés :
ruby2.1
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le dictionnaire CVE du Mitre : CVE-2015-1855.
Plus de précisions :

L'extension OpenSSL de Ruby, une partie de l'interpréteur pour le langage Ruby, n'implémentait pas correctement la comparaison de nom d'hôte, en violation de RFC 6125. Cela pourrait permettre à des attaquants distants de réaliser une attaque de l'homme du milieu grâce à des certificats SSL contrefaits.

Pour la distribution stable (Jessie), ce problème a été corrigé dans la version 2.1.5-2+deb8u1.

Pour la distribution testing (stretch), ce problème a été corrigé dans la version 2.1.5-3.

Pour la distribution unstable (Sid), ce problème a été corrigé dans la version 2.1.5-3.

Nous vous recommandons de mettre à jour vos paquets ruby2.1.