Bulletin d'alerte Debian

DSA-3256-1 libtasn1-6 -- Mise à jour de sécurité

Date du rapport :
10 mai 2015
Paquets concernés :
libtasn1-6
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le dictionnaire CVE du Mitre : CVE-2015-3622.
Plus de précisions :

Hanno Boeck a découvert un défaut de dépassement de tas dans la manière dont Libtasn1, une bibliothèque pour gérer les structures ASN.1, décodait certaines entrées encodées avec DER. Une entrée encodée avec DER contrefaite pour l'occasion pourrait provoquer le plantage d'une application utilisant la bibliothèque Libtasn1, ou éventuellement exécuter du code arbitraire.

Pour la distribution stable (Jessie), ce problème a été corrigé dans la version 4.2-3+deb8u1.

Pour la distribution testing (Stretch), ce problème a été corrigé dans la version 4.4-3.

Pour la distribution unstable (Sid), ce problème a été corrigé dans la version 4.4-3.

Nous vous recommandons de mettre à jour vos paquets libtasn1-6.