Рекомендация Debian по безопасности

DSA-3269-1 postgresql-9.1 -- обновление безопасности

Дата сообщения:
22.05.2015
Затронутые пакеты:
postgresql-9.1
Уязвим:
Да
Ссылки на базы данных по безопасности:
В каталоге Mitre CVE: CVE-2015-3165, CVE-2015-3166, CVE-2015-3167.
Более подробная информация:

В PostgreSQL-9.1, системе баз данных SQL, было обнаружено несколько уязвимостей.

  • CVE-2015-3165 (удалённое аварийное завершение работы)

    SSL-клиенты, разрывающие соединение до истечения срока аутентификации, могут вызвать аварийное завершение работы сервера.

  • CVE-2015-3166 (раскрытие информации)

    Новая реализация snprintf() не выполняет проверку ошибок, о которых сообщают подлежащие вызовы системной библиотеки; в первую очередь вероятно отсутствует проверка на чтение за пределами памяти. В худшем случае это может приводить к раскрытию информации.

  • CVE-2015-3167 (возможное раскрытие ключа через сторонний канал)

    contrib/pgcrypto в некоторых случаях расшифровки с некорректным ключом может выводить другой текст сообщения об ошибке. Исправлено путём использования сообщения one-size-fits-all.

В предыдущем стабильном выпуске (wheezy) эти проблемы были исправлены в версии 9.1.16-0+deb7u1.

В стабильном выпуске (jessie) эти проблемы были исправлены в версии 9.1.16-0+deb8u1. (Jessie содержит урезанный пакет postgresql-9.1; только CVE-2015-3166 исправлена в производном двоичном пакете postgresql-plperl-9.1. Рекомендуется выполнить обновление до пакета postgresql-9.4, чтобы получить полный набор исправлений. Подробности см. в информации о выпуске Jessie.)

В тестируемом (stretch) и нестабильном (sid) выпусках пакет postgresql-9.1 отсутствует.

Рекомендуется обновить пакеты postgresql-9.1.