Debians sikkerhedsbulletin

DSA-3301-1 haproxy -- sikkerhedsopdatering

Rapporteret den:
5. jul 2015
Berørte pakker:
haproxy
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Mitres CVE-ordbog: CVE-2015-3281.
Yderligere oplysninger:

Charlie Smurthwaite fra aTech Media opdagede en fejl i HAProxy, en hurtig og pålidelig load balancing-reverse proxy, når HTTP-pipelining anvendes. En klient kunne drage nytte af fejlen til at forårsage datakorruption og få adgang til uinitialiseret hukommelsesindhold, som udstiller data fra en tidligere forespørgsel eller session.

I den stabile distribution (jessie), er dette problem rettet i version 1.5.8-3+deb8u1.

I den ustabile distribution (sid), er dette problem rettet i version 1.5.14-1.

Vi anbefaler at du opgraderer dine haproxy-pakker.