Рекомендация Debian по безопасности

DSA-3301-1 haproxy -- обновление безопасности

Дата сообщения:
05.07.2015
Затронутые пакеты:
haproxy
Уязвим:
Да
Ссылки на базы данных по безопасности:
В каталоге Mitre CVE: CVE-2015-3281.
Более подробная информация:

Чарли Смартуэйт из aTech Media обнаружил уязвимость в HAProxy, быстром и надёжном обратном прокси с поддержкой балансировки нагрузки, которая появляется при использовании туннелирования HTTP. Клиент может использовать эту уязвимость для повреждения данных и получения содержимого неинициализированной памяти, в котором могут содержаться данные от предыдущих запросов или сессий.

В стабильном выпуске (jessie) эта проблема была исправлена в версии 1.5.8-3+deb8u1.

В нестабильном выпуске (sid) эта проблема была исправлена в версии 1.5.14-1.

Рекомендуется обновить пакеты haproxy.