Рекомендация Debian по безопасности

DSA-3318-1 expat -- обновление безопасности

Дата сообщения:
26.07.2015
Затронутые пакеты:
expat
Уязвим:
Да
Ссылки на базы данных по безопасности:
В системе отслеживания ошибок Debian: Ошибка 793484.
В каталоге Mitre CVE: CVE-2015-1283.
Более подробная информация:

В Expat, библиотеке для C для грамматического разбора XML, были обнаружены многочисленные переполнения целых чисел, которые могут приводить к отказу в обслуживании или выполнению произвольного кода в случае обработки некорректного файла в формате XML.

В предыдущем стабильном выпуске (wheezy) эта проблема была исправлена в версии 2.1.0-1+deb7u2.

В стабильном выпуске (jessie) эта проблема была исправлена в версии 2.1.0-6+deb8u1.

В нестабильном выпуске (sid) эта проблема была исправлена в версии 2.1.0-7.

Рекомендуется обновить пакеты expat.