Рекомендация Debian по безопасности

DSA-3364-1 linux -- обновление безопасности

Дата сообщения:
21.09.2015
Затронутые пакеты:
linux
Уязвим:
Да
Ссылки на базы данных по безопасности:
В системе отслеживания ошибок Debian: Ошибка 796036.
В каталоге Mitre CVE: CVE-2015-8215, CVE-2015-2925, CVE-2015-5156, CVE-2015-6252, CVE-2015-6937, CVE-2015-7312.
Более подробная информация:

В ядре Linux было обнаружено несколько уязвимостей, которые могут приводить к повышению привилегий или отказу в обслуживании.

  • CVE-2015-8215

    Было обнаружено, что NetworkManager устанавливает MTU для IPv6 на основе значений, получаемых в IPv6 RA (Router Advertisement), без проведения достаточной проверки этих значений. Удалённый злоумышленник может использовать эту атаку для отключения поддержки IPv6. Уязвимость была решена путём добавления в ядро проверяющего кода.

  • CVE-2015-2925

    Ян Хорн обнаружил, что если подкаталог файловой системы монтируется с опцией bind в контейнер, у которого имеется свой пользователь и пространство имён монтирования, то процесс, имеющий возможность CAP_SYS_ADMIN, в пользовательском пространстве имён может получить доступ к файлам за пределами этого подкаталога. Настройки по умолчанию в Debian снижают опасность такого поведения, так как не позволяют непривилегированным пользователям создавать новые пользовательские пространства имён.

  • CVE-2015-5156

    Джейсон Ванг обнаружил, что если устройство virtio_net подключено к мосту виртуальной машины, то последовательность TCP-пакетов, пересылаемых через этот мост, может приводить к переполнению динамической памяти. Удалённый злоумышленник может использовать эту уязвимость для вызова отказа в обслуживании (аварийное завершение) или повышения привилегий.

  • CVE-2015-6252

    Михаил Цыркин из Red Hat Engineering обнаружил, что драйвер vhost раскрывает файловые дескрипторы, передаваемые ему командой VHOST_SET_LOG_FD ioctl. Привилегированный локальный пользователь, имеющий доступ к файлу /dev/vhost-net напрямую или через libvirt, может использовать эту уязвимость для вызова отказа в обслуживании (зависание или аварийная остановка).

  • CVE-2015-6937

    Было обнаружено, что в реализации протокола RDS не выполняется проверка существования низлежащего транспортного протокола при создании подключения. В зависимости от того, как локальное RDS-приложение инициализирует свои сокеты, удалённый злоумышленник может получить возможность вызвать отказ в обслуживании (аварийная остановка) путём отправки специально сформированного пакета.

  • CVE-2015-7312

    Хавьер Чантри обнаружил, что заплата, предоставленная проектом aufs для исправления ошибки, при которой файлы MMIO на aufs приводили к состоянию гонки в системном вызове msync(). Бен Хатчингс обнаружил, что эта заплата добавляет похожую ошибку в функции madvise_remove(). Локальный злоумышленник может использовать эту уязвимость для вызова отказа в обслуживании или повышения привилегий.

В предыдущем стабильном выпуске (wheezy) эти проблемы были исправлены в версии 3.2.68-1+deb7u4. CVE-2015-2925 и CVE-2015-7312 не актуальны для выпуска wheezy.

В стабильном выпуске (jessie) эти проблемы были исправлены в версии 3.16.7-ckt11-1+deb8u4.

Рекомендуется обновить пакеты linux.