Bulletin d'alerte Debian

DSA-3374-1 postgresql-9.4 -- Mise à jour de sécurité

Date du rapport :
19 octobre 2015
Paquets concernés :
postgresql-9.4
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le dictionnaire CVE du Mitre : CVE-2015-5288, CVE-2015-5289.
Plus de précisions :

Plusieurs vulnérabilités ont été découvertes dans PostgreSQL-9.4, un système de base de données SQL.

  • CVE-2015-5288

    Josh Kupershmidt a découvert une vulnérabilité dans la fonction crypt() de l'extension pgCrypto. Certains arguments non valables de salt peuvent amener le serveur à planter ou à dévoiler quelques octets de la mémoire du serveur.

  • CVE-2015-5289

    Oskari Saarenmaa a découvert que des valeurs d'entrée json ou jsonb construites à partir d'une entrée arbitraire d'un utilisateur peuvent faire planter le serveur PostgreSQL et provoquer un déni de service.

Pour la distribution stable (Jessie), ces problèmes ont été corrigés dans la version 9.4.5-0+deb8u1.

Pour la distribution testing (Stretch), ces problèmes ont été corrigés dans la version 9.4.5-1.

Pour la distribution unstable (Sid), ces problèmes ont été corrigés dans la version 9.4.5-1.

Nous vous recommandons de mettre à jour vos paquets postgresql-9.4.