Рекомендация Debian по безопасности

DSA-3379-1 miniupnpc -- обновление безопасности

Дата сообщения:
25.10.2015
Затронутые пакеты:
miniupnpc
Уязвим:
Да
Ссылки на базы данных по безопасности:
В системе отслеживания ошибок Debian: Ошибка 802650.
В каталоге Mitre CVE: CVE-2015-6031.
Более подробная информация:

Александр Николик из Cisco Talos обнаружил переполнение буфера в коде для выполнения грамматического разбора XML в miniupnpc, легковесной клиентской библиотеке UPnP IGD. Удалённый злоумышленник может использовать данную уязвимость для аварийного завершения работы приложения, использующего библиотеку miniupnpc, либо для потенциального выполнения произвольного кода с правами пользователя, запустившего эти приложение.

В предыдущем стабильном выпуске (wheezy) эта проблема была исправлена в версии 1.5-2+deb7u1.

В стабильном выпуске (jessie) эта проблема была исправлена в версии 1.9.20140610-2+deb8u1.

В нестабильном выпуске (sid) эта проблема будет исправлена позже.

Рекомендуется обновить пакеты miniupnpc.