Debians sikkerhedsbulletin

DSA-3395-1 krb5 -- sikkerhedsopdatering

Rapporteret den:
6. nov 2015
Berørte pakker:
krb5
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Debians fejlsporingssystem: Fejl 803083, Fejl 803084, Fejl 803088.
I Mitres CVE-ordbog: CVE-2015-2695, CVE-2015-2696, CVE-2015-2697.
Yderligere oplysninger:

Flere sårbarheder blev opdaget i krb5, MIT's implementering af Kerberos. Projektet Common Vulnerabilities and Exposures har registreret følgende problemer:

  • CVE-2015-2695

    Man opdagede at applikationer, som kalder gss_inquire_context() i en delvist etableret SPNEGO-kontekst, kunne medføre at GSS-API-biblioteket læste fra en pointer med brug af den forkerte type, førende til nedbrud af en proces.

  • CVE-2015-2696

    Man opdagede at applikationer, som klader gss_inquire_context() i en delvist etableret IAKERB-kontektst, kunne medføre at GSS-API-biblioteket læste fra en pointer med brug af den forkerte type, førende til nedbrud af en proces.

  • CVE-2015-2697

    Man opdagede at funktionen build_principal_va() håndterede inddatastrenge på ukorrekt vis. En uautentificeret angriber kunne drage nytte af fejlen til at forårsage, at en KDC gik ned under en TGS-forespørgsel med et stort realm-felt, begyndende med en nullbyte.

I den gamle stabile distribution (wheezy), er disse problemer rettet i version 1.10.1+dfsg-5+deb7u4.

I den stabile distribution (jessie), er disse problemer rettet i version 1.12.1+dfsg-19+deb8u1.

I distributionen testing (stretch), er disse problemer rettet i version 1.13.2+dfsg-3.

I den ustabile distribution (sid), er disse problemer rettet i version 1.13.2+dfsg-3.

Vi anbefaler at du opgraderer dine krb5-pakker.