Рекомендация Debian по безопасности

DSA-3395-1 krb5 -- обновление безопасности

Дата сообщения:
06.11.2015
Затронутые пакеты:
krb5
Уязвим:
Да
Ссылки на базы данных по безопасности:
В системе отслеживания ошибок Debian: Ошибка 803083, Ошибка 803084, Ошибка 803088.
В каталоге Mitre CVE: CVE-2015-2695, CVE-2015-2696, CVE-2015-2697.
Более подробная информация:

В krb5, реализации Kerberos от MIT, было обнаружено несколько уязвимостей. Проект Common Vulnerabilities and Exposures определяет следующие проблемы:

  • CVE-2015-2695

    Было обнаружено, что приложения, вызывающие gss_inquire_context() на частично установленном контексте SPNEGO, могут приводить к чтению библиотекой GSS-API указателя, используя неверный тип, что приводит к аварийному завершению работы процесса.

  • CVE-2015-2696

    Было обнаружено, что приложения, вызывающие gss_inquire_context() на частично установленном контексте IAKERB, могут приводить к чтению библиотекой GSS-API указателя, используя неверный тип, что приводит к аварийному завершению работы процесса.

  • CVE-2015-2697

    Было обнаружено, что функция build_principal_va() неправильно обрабатывает входные строки. Аутентифицированный злоумышленник может использовать данную уязвимость, чтобы аварийно завершить работу KDC, используя запрос TGS с большим полем realm и начинающимся с null-байта.

В предыдущем стабильном выпуске (wheezy) эти проблемы были исправлены в версии 1.10.1+dfsg-5+deb7u4.

В стабильном выпуске (jessie) эти проблемы были исправлены в версии 1.12.1+dfsg-19+deb8u1.

В тестируемом выпуске (stretch) эти проблемы были исправлены в версии 1.13.2+dfsg-3.

В нестабильном выпуске (sid) эти проблемы были исправлены в версии 1.13.2+dfsg-3.

Рекомендуется обновить пакеты krb5.