Debians sikkerhedsbulletin

DSA-3398-1 strongswan -- sikkerhedsopdatering

Rapporteret den:
16. nov 2015
Berørte pakker:
strongswan
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Mitres CVE-ordbog: CVE-2015-8023.
Yderligere oplysninger:

Tobias Brunner fandt en sårbarhed i forbindelse med omgåelse af autentifikation i strongSwan, en IKE-/IPsec-programsamling.

På grund af utilstrækkelig validering af dets lokale status, kunne serverimplementeringen af EAP-MSCHAPv2-protokollen i plugin'en eap-mschapv2 narres til at afslutte autentifikationen med succes, uden at levere gyldige loginoplysninger.

Det er muligt at genkende sådanne angreb, ved at kigge i serverlogfilerne. Følgende fejlmeddelelse blev sendt under klientautentifikationen:

EAP method EAP_MSCHAPV2 succeeded, no MSK established

I den gamle stabile distribution (wheezy), er dette problem rettet i version 4.5.2-1.5+deb7u8.

I den stabile distribution (jessie), er dette problem rettet i version 5.2.1-6+deb8u2.

I distributionen testing (stretch), er dette problem rettet i version 5.3.3-3.

I den ustabile distribution (sid), er dette problem rettet i version 5.3.3-3.

Vi anbefaler at du opgraderer dine strongswan-pakker.