Рекомендация Debian по безопасности

DSA-3409-1 putty -- обновление безопасности

Дата сообщения:
01.12.2015
Затронутые пакеты:
putty
Уязвим:
Да
Ссылки на базы данных по безопасности:
В каталоге Mitre CVE: CVE-2015-5309.
Более подробная информация:

В коде обработки управляющей последовательности ECH (символа исключения) эмулятора терминала PuTTY было обнаружено переполнение целых чисел с повреждение содержимого памяти. Удалённый злоумышленник может использовать данную уязвимость для вызова отказа в обслуживании или потенциального выполнения произвольного кода.

В предыдущем стабильном выпуске (wheezy) эта проблема была исправлена в версии 0.62-9+deb7u3.

В стабильном выпуске (jessie) эта проблема была исправлена в версии 0.63-10+deb8u1.

В тестируемом выпуске (stretch) эта проблема была исправлена в версии 0.66-1.

В нестабильном выпуске (sid) эта проблема была исправлена в версии 0.66-1.

Рекомендуется обновить пакеты putty.