Debian Security Advisory

DLA-379-1 samba -- LTS security update

Date Reported:
03 Jan 2016
Affected Packages:
samba
Vulnerable:
Yes
Security database references:
In Mitre's CVE dictionary: CVE-2015-5252, CVE-2015-5296, CVE-2015-5299.
More information:

Several vulnerabilities were found in Samba, a SMB/CIFS implementation that provides a file, print, and login server.

  • CVE-2015-5252

    Jan Yenya Kasprzak and the Computer Systems Unit team at Faculty of Informatics, Masaryk University, reported that samba wrongly verified symlinks, making it possible to access resources outside the shared path, under certain circumstances.

  • CVE-2015-5296

    Stefan Metzmacher of SerNet and the Samba Team discovered that samba did not ensure that signing was negotiated when a client established an encrypted connection against a samba server.

  • CVE-2015-5299

    Samba was vulnerable to a missing access control check in the VFS shadow_copy2 module, that could allow unauthorized users to access snapshots.

For Debian 6 Squeeze, this issue has been fixed in samba version 2:3.5.6~dfsg-3squeeze13. We recommend you to upgrade your samba packages.