Debian Security Advisory

DLA-394-1 passenger -- LTS security update

Date Reported:
18 Jan 2016
Affected Packages:
passenger
Vulnerable:
Yes
Security database references:
In Mitre's CVE dictionary: CVE-2015-7519.
More information:

agent/Core/Controller/SendRequest.cpp in Phusion Passenger before 4.0.60 and 5.0.x before 5.0.22, when used in Apache integration mode or in standalone mode without a filtering proxy, allows remote attackers to spoof headers passed to applications by using an _ (underscore) character instead of a - (dash) character in an HTTP header, as demonstrated by an X_User header.