Debian Security Advisory

DLA-421-1 openssl -- LTS security update

Date Reported:
20 Feb 2016
Affected Packages:
openssl
Vulnerable:
Yes
Security database references:
In Mitre's CVE dictionary: CVE-2015-3197.
More information:
  • CVE-2015-3197:

    A malicious client can negotiate SSLv2 ciphers that have been disabled on the server and complete SSLv2 handshakes even if all SSLv2 ciphers have been disabled, provided that the SSLv2 protocol was not also disabled via SSL_OP_NO_SSLv2.

Additionally, when using a DHE cipher suite a new DH key will always be generated for each connection.

This will be the last security update for the squeeze version of the package. The 0.9.8 version is no longer supported and the squeeze LTS support will end soon. If you are using openssl you should upgrade to wheezy or preferably jessie. The version in those versions contain many security improvements.