Debians sikkerhedsbulletin

DLA-421-1 openssl -- LTS-sikkerhedsopdatering

Rapporteret den:
20. feb 2016
Berørte pakker:
openssl
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Mitres CVE-ordbog: CVE-2015-3197.
Yderligere oplysninger:
  • CVE-2015-3197:

    En ondsindet klient kunne forhandle SSLv2-ciphers, som er blevet deaktiveret på serveren, og gennemføre SSLv2-handshakes på trods af at alle SSLv2-ciphers er blevet deaktiveret, forudsat at SSLv2-protokollen ikke også var deaktiveret gennem SSL_OP_NO_SSLv2.

Desuden, når der anvendes en DHE-ciphersuite, blev en DH-nøgle altid genereret til hver forbindelse.

Dette er den sidste sikkerhedsopdatering af squeeze-udgaven af pakken. Versionen 0.9.8 er ikke længere understøttet og LTS-understøttelse af squeeze ophører snart. Hvis man anvender openssl, bør man opgradere til wheezy eller endnu bedre jessie. Versionen i disse udgaver indeholder mange sikkerhedsforbedringer.