Рекомендация Debian по безопасности

DLA-421-1 openssl -- обновление безопасности LTS

Дата сообщения:
20.02.2016
Затронутые пакеты:
openssl
Уязвим:
Да
Ссылки на базы данных по безопасности:
В каталоге Mitre CVE: CVE-2015-3197.
Более подробная информация:
  • CVE-2015-3197:

    Клиент-злоумышленник может согласовать использование шифра SSLv2, которые отключены на сервере, и завершить рукопожатие SSLv2 даже в том случае, если все шифры SSLv2 отключены, учитывая, что протокол SSLv2 не отключен с помощью опции SSL_OP_NO_SSLv2.

Кроме того, при использовании набора шифров DHE для каждого соединения всегда создаётся новый DH-ключ.

Данное обновление является последним обновлением для версии пакета в squeeze. Версия 0.9.8 более не поддерживается, долгосрочная поддержка squeeze вскоре закончится. Если вы используете openssl, то вам следует выполнить обновление до wheezy или jessie. Версия пакета в указанных выпусках содержит множество улучшений безопасности.