Bulletin d'alerte Debian

DSA-3441-1 perl -- Mise à jour de sécurité

Date du rapport :
11 janvier 2016
Paquets concernés :
perl
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le système de suivi des bogues Debian : Bogue 810719.
Dans le dictionnaire CVE du Mitre : CVE-2015-8607.
Plus de précisions :

David Golden de MongoDB a découvert que File::Spec::canonpath() dans Perl renvoyait des chaînes non teintées même si des entrées teintées étaient passées. Ce défaut ruine la propagation de l'étiquette teintée qui est parfois utilisée pour s'assurer que des entrées d'utilisateur non validées n'atteignent pas du code sensible.

La distribution oldstable (Wheezy) n'est pas concernée par ce problème.

Pour la distribution stable (Jessie), ce problème a été corrigé dans la version 5.20.2-3+deb8u2.

Pour la distribution unstable (Sid), ce problème sera corrigé prochainement.

Nous vous recommandons de mettre à jour vos paquets perl.