Bulletin d'alerte Debian

DSA-3443-1 libpng -- Mise à jour de sécurité

Date du rapport :
13 janvier 2016
Paquets concernés :
libpng
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le système de suivi des bogues Debian : Bogue 807112, Bogue 807694.
Dans le dictionnaire CVE du Mitre : CVE-2015-8472, CVE-2015-8540.
Plus de précisions :

Plusieurs vulnérabilités ont été découvertes dans la bibliothèque PNG libpng. Le projet « Common Vulnerabilities and Exposures » (CVE) identifie les problèmes suivants :

  • CVE-2015-8472

    le correctif original pour CVE-2015-8126 était incomplet et ne détectait pas un dépassement de tampon potentiel par les applications utilisant png_set_PLTE directement. Un attaquant distant peut tirer avantage de ce défaut pour provoquer un déni de service (plantage de l'application).

  • CVE-2015-8540

    Xiao Qixue et Chen Yu ont découvert un défaut dans la fonction png_check_keyword. Un attaquant distant peut éventuellement tirer avantage de ce défaut pour provoquer un déni de service (plantage de l'application).

Pour la distribution oldstable (Wheezy), ces problèmes ont été corrigés dans la version 1.2.49-1+deb7u2.

Pour la distribution stable (Jessie), ces problèmes ont été corrigés dans la version 1.2.50-2+deb8u2.

Nous vous recommandons de mettre à jour vos paquets libpng.