Bulletin d'alerte Debian

DSA-3455-1 curl -- Mise à jour de sécurité

Date du rapport :
27 janvier 2016
Paquets concernés :
curl
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le dictionnaire CVE du Mitre : CVE-2016-0755.
Plus de précisions :

Isaac Boukris a découvert que cURL, une bibliothèque de transfert d'URL, réutilisait des connexions de mandataires authentifiées par NTLM sans s'assurer correctement que la connexion était authentifiée avec la même accréditation que celle établie pour le nouveau transfert. Cela pourrait conduire à ce que des requêtes HTTP soient envoyées sur la connexion authentifiée sous un autre identifiant.

Pour la distribution stable (Jessie), ce problème a été corrigé dans la version 7.38.0-4+deb8u3.

Pour la distribution unstable (Sid), ce problème a été corrigé dans la version 7.47.0-1.

Nous vous recommandons de mettre à jour vos paquets curl.