Debians sikkerhedsbulletin

DSA-3546-1 optipng -- sikkerhedsopdatering

Rapporteret den:
7. apr 2016
Berørte pakker:
optipng
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Mitres CVE-ordbog: CVE-2016-2191, CVE-2016-3981, CVE-2016-3982.
Yderligere oplysninger:

Hans Jerry Illikainen opdagede at manglende fornuftighedskontrol af inddata i koden til BMP-behandling i optipng PNG-optimiseren, kunne medføre lammelsesangreb (denial of service) eller udførelse af vilkårlig kode, hvis en misdannet fil blev behandlet.

I den gamle stabile distribution (wheezy), er dette problem rettet i version 0.6.4-1+deb7u2. Opdateringen retter også CVE-2015-7801, som oprindelig var tiltænkt en punktopdatering af wheezy.

I den stabile distribution (jessie), er dette problem rettet i version 0.7.5-1+deb8u1.

I den ustabile distribution (sid), vil dette problem snart blive rettet.

Vi anbefaler at du opgraderer dine optipng-pakker.