Рекомендация Debian по безопасности

DSA-3546-1 optipng -- обновление безопасности

Дата сообщения:
07.04.2016
Затронутые пакеты:
optipng
Уязвим:
Да
Ссылки на базы данных по безопасности:
В каталоге Mitre CVE: CVE-2016-2191, CVE-2016-3981, CVE-2016-3982.
Более подробная информация:

Ханс Джерри Илликаинен обнаружил, что отсутствие очистки входных данных в коде обработки BMP в optipng, программе для оптимизации PNG, может приводить к отказу в обслуживании или выполнению произвольного кода в случае обработки специально сформированного файла.

В предыдущем стабильном выпуске (wheezy) эта проблема была исправлена в версии 0.6.4-1+deb7u2. Кроме того, данное обновление исправляет CVE-2015-7801, что планировалось сделать в следующем обновлении редакции wheezy.

В стабильном выпуске (jessie) эта проблема была исправлена в версии 0.7.5-1+deb8u1.

В нестабильном выпуске (sid) эта проблема будет исправлена позже.

Рекомендуется обновить пакеты optipng.