Säkerhetsbulletin från Debian

DSA-3546-1 optipng -- säkerhetsuppdatering

Rapporterat den:
2016-04-07
Berörda paket:
optipng
Sårbara:
Ja
Referenser i säkerhetsdatabaser:
I Mitres CVE-förteckning: CVE-2016-2191, CVE-2016-3981, CVE-2016-3982.
Ytterligare information:

Hans Jerry Illikainen upptäckte att saknad rengörning av indata i BMP-behandlingskoden i PNG-optimeraren optipng kan resultera i överbelastning eller körning av godtycklig kod om en felaktigt formatterad fil behandlas.

För den gamla stabila utgåvan (Wheezy) har detta problem rättats i version 0.6.4-1+deb7u2. Denna uppdatering rättar även CVE-2015-7801, som ursprungligen var tänkt för en punktutgåva av wheezy.

För den stabila utgåvan (Jessie) har detta problem rättats i version 0.7.5-1+deb8u1.

För den instabila utgåvan (Sid) kommer detta problem att rättas inom kort.

Vi rekommenderar att ni uppgraderar era optipng-paket.