Debian Security Advisory

DSA-3553-1 varnish -- security update

Date Reported:
22 Apr 2016
Affected Packages:
varnish
Vulnerable:
Yes
Security database references:
In the Debian bugtracking system: Bug 783510.
In Mitre's CVE dictionary: CVE-2015-8852.
More information:

RĂ©gis Leroy from Makina Corpus discovered that varnish, a caching HTTP reverse proxy, is vulnerable to HTTP smuggling issues, potentially resulting in cache poisoning or bypassing of access control policies.

For the oldstable distribution (wheezy), this problem has been fixed in version 3.0.2-2+deb7u2.

We recommend that you upgrade your varnish packages.