Bulletin d'alerte Debian

DSA-3556-1 libgd2 -- Mise à jour de sécurité

Date du rapport :
24 avril 2016
Paquets concernés :
libgd2
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le système de suivi des bogues Debian : Bogue 822242.
Dans le dictionnaire CVE du Mitre : CVE-2016-3074.
Plus de précisions :

Hans Jerry Illikainen a découvert que libgd2, une bibliothèque pour la création et la manipulation programmées d'images, souffre d'une vulnérabilité de gestion de signe qui peut avoir pour conséquence un dépassement de zone de mémoire du système lors du traitement de données gd2 compressées contrefaites pour l'occasion. Un attaquant distant peut tirer avantage de ce défaut pour provoquer le plantage d'une application utilisant la bibliothèque libgd2, ou éventuellement, pour exécuter du code arbitraire avec les droits de l'utilisateur exécutant l'application.

Pour la distribution oldstable (Wheezy), ce problème a été corrigé dans la version 2.0.36~rc1~dfsg-6.1+deb7u2.

Pour la distribution stable (Jessie), ce problème a été corrigé dans la version 2.1.0-5+deb8u1.

Pour la distribution unstable (Sid), ce problème a été corrigé dans la version 2.1.1-4.1.

Nous vous recommandons de mettre à jour vos paquets libgd2.