Debians sikkerhedsbulletin

DSA-3570-1 mercurial -- sikkerhedsopdatering

Rapporteret den:
5. maj 2016
Berørte pakker:
mercurial
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Mitres CVE-ordbog: CVE-2016-3105.
Yderligere oplysninger:

Blake Burkhart opdagede en fejl i forbindelse med udførelse af vilkårlig kode i Mercurial, et distribueret versionsstyringssystem, når convert-udvidelsen blev benyttet på Git-repositories med særligt fremstillede navne. Fejlen påvirker i særdeleshed automaticerede kodekonverteringstjenester, som tillader vilkårlige repositorynavne.

I den stabile distribution (jessie), er dette problem rettet i version 3.1.2-2+deb8u3.

I den ustabile distribution (sid), er dette problem rettet i version 3.8.1-1.

Vi anbefaler at du opgraderer dine mercurial-pakker.